ubuntu的应用程序的系统兼容性是看哪个的,ubun

2019-12-19 09:43栏目:网络操作
TAG:

现在我在ubuntu14.04LTS,内核是3.13.0-24generic的环境下编译了一个Qt程序。用户机器上的环境是Ubuntu18.04.2LTS,内核是3.10.0-693.el7.x86_64。那我编的程序能否在用户机器上跑。ubuntu的应用程序的系统兼容性是看哪个的?是看内核版本号还是系统版本号?是不是高版本的一定能兼容低版本的?请各位大侠指教一下。

 uname -a

1.查看ubuntu版本号:

dpkg --get-selections [<表达式> ...] 把已选中的软件包列表打印到标准输出;

uname -r

uname -a 查看已安装的linux内核版。

 

3.ubuntu内核版本管理:

 

2.卸载旧的内核版本,在终端里输入命令:

方法三:

澳门新葡亰平台游戏,Release:    6.06

返回结果:

 

 

Ubuntu内核版本管理

Description:    Ubuntu 6.06.2 LTS

然后会显示系统中已安装的内核,例如:

方法二:

2.查看内核版本号:

返回结果:

Distributor ID:    Ubuntu

 cat /etc/lsb-release

dpkg --get-selections | grep linux-image

cat  /etc/issue

澳门新葡亰平台官网,1.查看ubuntu版本号:

Linux jpsiteserver 2.6.15-51-386 #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007 i686 GNU/Linux 

cat /proc/version 

DISTRIB_RELEASE=6.06

方法五:

返回结果:

方法六:仅仅查看内核版本

Codename:    dapper

Ubuntu 6.06.2 LTS n l

cat /proc/version 

返回结果:

Codename:    dapper

返回结果:

Release:    6.06

 返回结果:

 

cat  /etc/issue

目录(?)[+]

linux-image-3.0.0-19-generic   install

返回结果:

linux-image-3.0.0-12-generic   install

 

 

sudo lsb_release -a

 cat /etc/lsb-release

方法一:

返回结果:

2.6.15-51-386

sudo apt-get remove linux-image-3.0.0-12-generic linux-image-3.0.0-19-generic  

返回结果:

DISTRIB_ID=Ubuntu

1.查看ubuntu版本号:

   www.2cto.com  

返回结果:

方法四:

 

Linux version 2.6.15-51-386 ([email protected]) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007

 返回结果:

Codename:    dapper

方法四:

返回结果:

方法六:仅仅查看内核版本

返回结果:

2.6.15-51-386

Linux jpsiteserver 2.6.15-51-386 #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007 i686 GNU/Linux

Description:    Ubuntu 6.06.2 LTS

linux-image-3.0.0-20-generic   install

 uname -a

 

Distributor ID:    Ubuntu

1.查看ubuntu版本号: 方法一: cat /etc/issue 返回结果: Ubuntu 6.06.2 LTS n l www.2cto.com 方法二: sudo lsb_release -a 返回结果:...

cat /proc/version 

Description:    Ubuntu 6.06.2 LTS

方法一:

 

DISTRIB_CODENAME=dapper

DISTRIB_CODENAME=dapper

方法四:

1.找出系统已经安装的内核版本,在终端里输入命令:

Linux jpsiteserver 2.6.15-51-386 #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007 i686 GNU/Linux 

uname -r

DISTRIB_RELEASE=6.06

grep linux-image 匹配查找;

方法五:

 

返回结果:

 

 

 

 

 

DISTRIB_ID=Ubuntu

2.6.15-51-386

 

DISTRIB_RELEASE=6.06

No LSB modules are available.

linux-image-generic    install

 返回结果:

DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"

方法三:

方法二:

cat  /etc/issue

No LSB modules are available.

ubuntu命令查询版本和内核版本

sudo lsb_release -a

方法二:

[email protected]:~$ dpkg --get-selections | grep linux-image

DISTRIB_ID=Ubuntu

方法三:

 

方法一:

返回结果:

返回结果:

Ubuntu 6.06.2 LTS n l

 

1.查看ubuntu版本号: 方法一: cat /etc/issue 返回结果: Ubuntu 6.06.2 LTS n l 方法二: sudo lsb_release -a 返回结果:...

 

方法五:

2.查看内核版本号:

sudo lsb_release -a

返回结果:

Linux version 2.6.15-51-386 ([email protected]) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007

No LSB modules are available.

 uname -a

Release:    6.06

Linux version 2.6.15-51-386 ([email protected]) (gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 PREEMPT Tue Oct 23 21:42:16 UTC 2007

 

方法六:仅仅查看内核版本

DISTRIB_CODENAME=dapper

 cat /etc/lsb-release

2.查看内核版本号:

DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"

uname -r

Distributor ID:    Ubuntu

Ubuntu 6.06.2 LTS n l

DISTRIB_DESCRIPTION="Ubuntu 6.06.2 LTS"

版权声明:本文由澳门新葡亰平台游戏发布于网络操作,转载请注明出处:ubuntu的应用程序的系统兼容性是看哪个的,ubun